[SailfishDevel] Cannot deploy application since SDK upgrade

Luciano Montanaro mikelima at gmail.com
Tue Oct 29 08:52:05 UTC 2013


On Mon, Oct 28, 2013 at 3:38 PM, Artem Marchenko
<artem.marchenko at gmail.com> wrote:
> I am not sure if I had absolutely the same issue, but something that looked
> similar.
>
> I also had a subdirs project and after SDK upgrade only one of the
> subprojects is runnable if you select RPM deployment even for i486 target
> and for the not-runnable one you cannot select the alternative executable
> nor you can create a custom configuration (well, you can, but it will try to
> run it on the build machine).
>

Thank you, my configuration is similar, I have a testing subproject,
that has not been built in a while, but the project files still are
using the subdir...

I can confirm that I was deploying to the emulator, and not the yet
unavailable ARM target.

I also tried opening a project directly in the application
directory... but my rpm dir is one level above, so it would not work
without some change. May this be a problem, in general?

I tried out another "exercise" project I have around, and the run icon
seem to work. But it is a simple QML application.


> Workaround that I found:
>
> 1. Run the subproject that is fine with RPM deployment (one of my subproject
> was fine, maybe it's always the last one that is fine?). That will install
> the dependencies to emulator
>
> 2. Switch to deployment by copying binaries. Then you will be able to
> specify the alternative executable and custom command line arguments. Sure
> then your code will be run from /opt , not from /usr , but for my project it
> was good enough, I just have to remember which command line arguments to
> supply to the test suite (my second project was a test suite).
>
> Same thing is summarized in the demo project at
> https://github.com/amarchen/sailfish-app-with-qml-test , but of course
> something might be a little wrong. E.g. I think it mentions custom
> executable to be used at /usr, while deploying by binary copy deploys to
> /opt... a fix in docs is needed, pull requests are welcome :)
>

I will try this. Actually, I will try to install the RPM via zypper.
If that works, I can live with that for now. I just want to see the
application finished...

I have some trouble figuring out how to change the user interface to
fit SailfishOS, but in general, I like what I see: for many parts of
the Harmattan application, I had to create custom components, while
for SailfishOS, it looks like the components are already available,
and quite close to what I actually had to implement.

Anybody knows if a SectionScroller component is going to be available
for Silica? I would like to add that, since I have a list of a few
thousands train stations to display, and being able to quickly scroll
to the right part of the list would be useful.


Best regards,
Luciano




> Cheers,
> Artem.
>
>
> On Mon, Oct 28, 2013 at 4:04 PM, Juha Kallioinen <juha.kallioinen at jolla.com>
> wrote:
>>
>> On 28.10.2013 11:21, Luciano Montanaro wrote:
>>>
>>> Hi everybody,
>>>
>>> since I upgraded to the latest SDK release, I can no longer deploy my
>>> application.
>>>
>>> The RPM is built correctly, after the emulator update, but the "run"
>>> icon is grayed out, and in the "project" page, the "run" configuration
>>> warns that the application path is missing. The text edits to set
>>> custom executable/path are disabled, so I cannot fix this manually...
>>>
>>> Maybe this is due to how my project is structured?
>>> I have a main project of type subdirs, with the code/resources in the
>>> "application" folder. Also, there are conditionals to select
>>> maemo5/harmattan/sailfish specific options; maybe these are preventing
>>> the automatic detection of the executable.
>>> However the TARGET" is not under any condition at all...
>>>
>>> Any suggestion?
>>
>>
>> The updated SDK release installs two targets; one ARM target and one i486
>> target. The ARM target has no official device support yet, so the Run method
>> is not available. Please double check that you are using the i486 target if
>> you want to deploy your project to the emulator.
>>
>> The target names are SailfishOS-armv7hl (for ARM) and SailfishOS-i486-x86
>> (for i486).
>>
>> If you are sure that you indeed have the i486 selected then let's explore
>> this problem further.
>>
>> Best regards,
>>  Juha
>>
>>
>> _______________________________________________
>> SailfishOS.org Devel mailing list
>
>
>
>
> --
> Artem Marchenko
> http://agilesoftwaredevelopment.com
> http://twitter.com/AgileArtem



-- 
Luciano Montanaro

Anyone who is capable of getting themselves made President should on
no account be allowed to do the job. -- Douglas Adams


More information about the Devel mailing list