[SailfishDevel] Include Python.h: BuildRequires

Jonni Rainisto jonni.rainisto at jollamobile.com
Fri Aug 9 08:44:58 UTC 2013


You are trying to pkgconfig stuff that doesn't have corresponding .pc 
file. In mersdk vm, if you "su -l mersdk" and do "sb2 ls 
/usr/lib/pkgconfig" you can see available pkgconfig packages. If there 
is no pkgconfig package avail then you most likely just need to 
BuildRequire the -devel package that you need.

So in reality you want to do something like:
BuildRequires:  pkgconfig(Qt5Core)
BuildRequires:  pkgconfig(Qt5Qml)
BuildRequires:  pkgconfig(Qt5Gui)
BuildRequires:  pkgconfig(qdeclarative5-boostable)
BuildRequires:  telepathy-qt5-devel
BuildRequires:  libcontacts-qt5-devel
BuildRequires:  desktop-file-utils

re, Jonni

On 08/09/2013 11:03 AM, christopher.lamb at thurweb.ch wrote:
> Hi Jonni
>
> Could you clarify you answer here:
>
> Zitat von "Jonni Rainisto" <jonni.rainisto at jollamobile.com>:
>
>> Other option would just to add depency to spec file (or to yaml), 
>> that way package gets automatically installed to toolchain while 
>> building.
>>
>> BuildRequires:  pkgconfig(python-2.7)
>>
>
> In my case the Build fails with an explicit error, rather than 
> automatically installing the stated packages.
>
> As an example, I am playing around with a project that has the 
> following in the .spec file
>
>
> BuildRequires:  pkgconfig(QtCore) >= 4.7.0
> BuildRequires:  pkgconfig(QtDeclarative)
> BuildRequires:  pkgconfig(QtContacts)
> BuildRequires:  pkgconfig(qdeclarative-boostable)
> BuildRequires:  pkgconfig(TelepathyQt5)
> BuildRequires:  desktop-file-utils
>
> When I build I get the following in the compile output
>
> '
> (....)
> pkgconfig(TelepathyQt5)' not found in package names. Trying capabilities.
> 'telepathy-qt5-devel' providing 'pkgconfig(TelepathyQt5)' is already 
> installed.
> (....)
> 'pkgconfig(QtContacts)' not found in package names. Trying capabilities.
> 'pkgconfig(qdeclarative-boostable)' not found in package names. Trying 
> capabilities.
> error: Failed build dependencies:
>     pkgconfig(QtContacts) is needed by qmlmessages-0.1.4-1.i586
>     pkgconfig(qdeclarative-boostable) is needed by 
> qmlmessages-0.1.4-1.i586
>
> '
>
> Have I missed an option that allows automatic install?
>
> If an automatic install is not possible, is there a clever way to 
> identify the correct package(s) and install using the SDK Control 
> Center? E.g. If I search for "contact" in the Control Center then I 
> get a long list of possible packages with contact in the name, and it 
> is not easy (for me) to identify the correct one without a bit of 
> trial and error.
>
> thanks
>
> Crhis
>
>
>
>
>
>



More information about the Devel mailing list