[SailfishDevel] QTLocation not part of QT5, what to do?

Aaron McCarthy aaron.mccarthy at jollamobile.com
Thu Aug 8 00:38:30 UTC 2013

On Wed, 7 Aug 2013 05:34:14 PM christopher.lamb at thurweb.ch wrote:
> > "I believe the goal for QtLocation to be included with Qt is 5.2..."
> But isn't QtLocation included in the SailfishAlpha 2 ?
> I am confused on this: In the Alpha2 toolchain I find
> /Users/christopherlamb/SailfishOSAlpha5/mersdk/targets/SailfishOS-i486-
> sr/lib/qt5/qml/QtLocation.
> The SDK Control Center also shows qt5-qtlocation is installed in the
> toolchain.

Qt Location will be included in the SDK.

> On the Emulator, "zypper se location" showed qt5-qtlocation was not
> installed, so I ran "zypper in qt5-qtlocation".
> However when I ran my app, I get the error
> "
> module "QtLocation" is not installed
>       import QtLocation 5.0
> "

qt5-qtlocation includes only the C++ library. To use with QML you will also 

qt5-qtdeclarative-import-location the QML import plugin

and at least one geoservices plugin, either qt5-qtlocation-plugin-
geoservices-nokia or qt5-qtlocation-plugin-geoservices-osm

> Curiously I can't find where zypper installed QtLocation on the
> Emulator. I had expected to find it somewhere near /usr/lib/qt5/qml

rpm -ql qt5-qtlocation will list the files included in the package.


Aaron McCarthy
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.sailfishos.org/pipermail/devel/attachments/20130808/26c71db9/attachment.html>

More information about the Devel mailing list