[SailfishDevel] qt upgrade

Lukáš Karas lukas.karas at centrum.cz
Sun Feb 10 11:20:31 UTC 2019


Hi all

> 
> To sum up, no idea how much we can help with 5.9 transition and what's
> holding it back specifically.
> 

>From the Fosdem discussion, I feel like there is no big technical issue. 
There was message that majority of SFOS core components already has branches 
prepared for Qt 5.9. Issue with transition is licensing - more Qt components 
was switched from LGPLv2.1 license to LGPLv3 [1]. If I understand it 
correctly, LGPLv2 guarantees you as a user that you will get source code for 
the library and you should be able to update library without application 
modification - it allows proprietary applications to link shared Qt 
libraries... But this second right is not mentioned explicitly. It is fixed in 
LGPLv3 that guarantee to user that have to be possible to replace libraries.

This is not problem for SFOS itself, when you can get root access just by one 
click. But for some Jolla partners, that want to create certified devices for 
governments, this right may be a problem. Noone mention specific companies, 
but it is clear that Jolla needs approval from their partners first...

Lukas 

1) https://blog.qt.io/blog/2014/08/20/adding-lgpl-v3-to-qt/
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 488 bytes
Desc: This is a digitally signed message part.
URL: <https://lists.sailfishos.org/pipermail/devel/attachments/20190210/4be4e437/attachment.sig>


More information about the Devel mailing list