[SailfishDevel] Using QtBluetooth 5.4 Backport in a harbour-app

Harald Schmitt linux at hschmitt.de
Sat Jan 17 11:29:06 UTC 2015


Am 08.01.2015 um 11:13 schrieb Harald Schmitt:
> Am 05.01.2015 um 01:56 schrieb Aaron McCarthy:
>> On Mon, 15 Dec 2014 17:53:34 Harald Schmitt wrote:
>>> Am 15.12.2014 um 13:35 schrieb Harald Schmitt:
>>>> Am 11.12.2014 um 17:45 schrieb Harald Schmitt:
>>>>> Am 10.12.2014 um 18:24 schrieb Richard Rondu:
>>>>>> Hi, the backport is not completely up-to-date with QtBluetooth 5.4, I
>>>>>> have to update it. Nevertheless It should work with standard
>>>>>> bluetooth, I haven't tried with BLE though.
>>>>>> Other part of QtConnectivity that are not QtBluetooth haven't been
>>>>>> tried either (NFC and so on). I even think I have even disabled the
>>>>>> build.
>>>>>>
>>>>>> Nevertheless, here are the relevant part of the .yaml file and the
>>>>>> .pro file I use for "Parrot ZIK 2.0 Manager" in  harbour that ship
>>>>>> with this backport.
>>>>>>
>>>>>> You have to build QtBluetooth backport separately with the sailfish
>>>>>> sdk, then put the .so file(s) in a "lib" subdirectory inside your
>>>>>> project.
>>>>> thanks that got me started. I hope I can dedicate enough time to bring a
>>>>> Xiaomi MiBand app to the harbour.
>>>> While building qtconnectivity with the sdk I get the following message
>>>>
>>>> Project MESSAGE: Unsupported Bluetooth platform, will not build a
>>>> working QtBluetooth library.
>>>>
>>>> Project MESSAGE: Either no Qt D-Bus found or no BlueZ headers.
>>>>
>>>>
>>>> qtHaveModule(dbus) returns false. Do you have any idea?
>>> I made a mistake, actually config_bluez returns false and
>>> qtHaveModule(dbus) returns true. But still I don't know why.
>> Try to determine why the BlueZ config test failed. You can manually try to 
>> build the config test project in qtconnectivity/config.tests/bluez. It uses 
>> pkgconfig to find the required headers and libraries. Ensure that the required 
>> development packages are installed.
> Thanks, it works now. I can connect to a BLE device using the
> QLowEnergyController class if I know the device address.
> The discovery does not find BLE devices only normal Bluetooth devices.
After updating to the latest sdk
(SailfishOSSDK-Beta-1412-Qt5-linux-64-offline.run) the bib did not build
alltough I added the required library (bluez-libs-devel) and synced the
target within qt creator it did not sucessfully do the
qtCompileTest(bluez)
After numerous tries I added the line
CONFIG+=recheck
with this qt does not cache the qtCompileTest results.
This did the trick and after one build I could remove the line again and
even after qtcreator restart it builds correctly.
Strange!!!


More information about the Devel mailing list