[SailfishDevel] Problems deploying with SDK 1412

Tone Kastlunger users.giulietta at gmail.com
Thu Jan 8 21:25:57 UTC 2015


It seems I am facing a similar problem, but on the pc side (win7):

Fatal: No spec file found in '/home/mersdk/share//debota/rpm/' and couldn't
make one from a yaml #1

23:23:58: The process
"C:\sviluppo\sailfish\sdk\settings\SailfishBeta1\mer-sdk-tools\MerSDK\SailfishOS-armv7hl\rpm.cmd"
exited with code 1.

Error while building/deploying project debota-sailfish (kit:
MerSDK-SailfishOS-armv7hl)

When executing step 'Rpm'

I wonder when this broke? It used to work in the last release.

PS : the echo off in the rpm.cmd is really misleading for managing errors
like these...

On Thu, Jan 8, 2015 at 9:16 PM, Krisztian Olah <fasza2mobile at gmail.com>
wrote:

> Thanks Michael,
> Creating the /opt/sdk/ path seems to have soved the issue, I can't
> remember ever having to do this manually. I very recently restored my Jolla
> to factory settings so that might have had something to do with it as well.
>
> Thanks again
> Kris
>
> On 8 January 2015 at 18:35, Michael Neufing <michael at neufing.org> wrote:
>
>> Hi Kris,
>>
>> are you using deployment by copying binaries to device?
>> If yes, can you check if the folder /opt/sdk exists on your device? If
>> not, create it and test again.
>> This solved my problems with this deployment mode.
>>
>> You could also set the deployment mode to RPM.
>>
>> Michael.
>>
>>
>>
>> Zitat von Krisztian Olah <fasza2mobile at gmail.com>:
>>
>>
>>  Hi list,
>>> I installed the new SDK yesterday, but since it's installed I cant seem
>>> to
>>> be able to deploy onto device fails due to an rsync error:
>>>
>>> rsync: mkdir "/opt/sdk/Trash" failed: No such file or directory (2)
>>>
>>> rsync error: error in file IO (code 11) at main.c(656) [Receiver=3.1.0]
>>>
>>> Deploy failed
>>>
>>> rsync: [sender] write error: Broken pipe (32)
>>>
>>> 16:50:40: The process
>>> "/home/kriszik_arch/.config/SailfishBeta1/mer-sdk-tools/
>>> MerSDK/SailfishOS-armv7hl/deploy"
>>> exited with code 1.
>>>
>>> Error while building/deploying project Trash (kit:
>>> MerSDK-SailfishOS-armv7hl)
>>>
>>> When executing step 'Rsync'
>>>
>>>
>>> This is the boilerplate project that is preset by Jolla upon choosing
>>> SailfishOS for new project, but same thing happens with my project too.
>>> SSH
>>> works as it's supposed to, the SDK's connection test reports success, but
>>> deploy fails. I didn't try with the emulator, becase I do not wish to
>>> work
>>> with it even if it worked. I tried to reinstall, checked md5, cleared
>>> .config (I am on Arch linux x86_64 KDE), but as of now no luck. Is there
>>> anything I might have missed?
>>>
>>>
>>> I would appricate any insight.
>>>
>>> Thanks
>>>
>>> Kris
>>>
>>
>>
>> _______________________________________________
>> SailfishOS.org Devel mailing list
>> To unsubscribe, please send a mail to devel-unsubscribe at lists.
>> sailfishos.org
>>
>
>
> _______________________________________________
> SailfishOS.org Devel mailing list
> To unsubscribe, please send a mail to
> devel-unsubscribe at lists.sailfishos.org
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.sailfishos.org/pipermail/devel/attachments/20150108/5d280df7/attachment.html>


More information about the Devel mailing list