[SailfishDevel] SDK installation error on Debian stable (VirtualBox 4.1.18)

Jarkko Lehtoranta jarkko.lehtoranta at jolla.com
Fri Nov 28 21:07:01 UTC 2014

On 27/11/14 09:50, Alejandro Exojo wrote:
> El Tuesday 25 November 2014, Alejandro Exojo escribió:
>> El Tuesday 25 November 2014, Alejandro Exojo escribió:
>>> Error during installation process (org.merproject.mersdk):
>>> Execution failed(Unexpected exit code: 1): "/usr/bin/VBoxManage
>>> storagectl MerSDK --name SATA --add sata --controller IntelAhci
>>> --portcount 1 --bootable  on"
>>> In the console I get:
>>> VBoxManage: error: Unknown option: --portcount
>> I worked around it simply running the command without said options. Seems
>> to work just as well (I got to compile and run on the emulator), but I'll
>> have to test the SDK more throughly.
> I forgot to add one more thing: this all applies to the latest, Beta1 SDK.
> Previous versions worked out of the box. With the workaround, on Debian stable
> works fine. In other distro with a newer VirtualBox I didn't get the error,
> and worked fine as well.
> Are the sources for the installer online? I couldn't find them in
> github/sailfish-sdk. It would be a trivial patch, and a pull request would be
> harder to get lost.
At the moment the installer sources are not available in a public repo.

Looks like "sataportcount" was used in vbox <4.3 and it was renamed to 
"portcount" in newer versions. I'll add to the todo list to fix the 
handling of this among different vbox versions.

Btw. oracle's vbox 4.3 is available for debian squeeze and wheezy via 
their own repos: https://www.virtualbox.org/wiki/Linux_Downloads.

More information about the Devel mailing list