[SailfishDevel] SDK installation error on Debian stable (VirtualBox 4.1.18)

Alejandro Exojo suy at badopi.org
Thu Nov 27 07:50:39 UTC 2014

El Tuesday 25 November 2014, Alejandro Exojo escribió:
> El Tuesday 25 November 2014, Alejandro Exojo escribió:
> > Error during installation process (org.merproject.mersdk):
> > Execution failed(Unexpected exit code: 1): "/usr/bin/VBoxManage
> > storagectl MerSDK --name SATA --add sata --controller IntelAhci
> > --portcount 1 --bootable  on"
> > 
> > In the console I get:
> > 
> > VBoxManage: error: Unknown option: --portcount
> I worked around it simply running the command without said options. Seems
> to work just as well (I got to compile and run on the emulator), but I'll
> have to test the SDK more throughly.

I forgot to add one more thing: this all applies to the latest, Beta1 SDK. 
Previous versions worked out of the box. With the workaround, on Debian stable 
works fine. In other distro with a newer VirtualBox I didn't get the error, 
and worked fine as well.

Are the sources for the installer online? I couldn't find them in 
github/sailfish-sdk. It would be a trivial patch, and a pull request would be 
harder to get lost.

Alex (a.k.a. suy) | GPG ID 0x0B8B0BC2
http://barnacity.net/ | http://disperso.net

More information about the Devel mailing list