[SailfishDevel] Binding weirdness on Jolla device after deploy with screen locked

Kimmo Lindholm Kimmo.Lindholm at eke.fi
Mon Jan 27 08:27:45 UTC 2014


Confirm this too. 

Had a "hearbeat" counter between C and QML. (wrote from QML , C increments +1 and emits signal that it is changed)

This was not incremented if i started app from command line (ssh) when screen locked.

-kimmo



________________________________________
Lähettäjä: devel-bounces at lists.sailfishos.org [devel-bounces at lists.sailfishos.org] käyttäjän Tero Siironen [izero79 at gmail.com] puolesta
Lähetetty: 27. tammikuuta 2014 07:50
Vastaanottaja: Sailfish OS Developers
Aihe: Re: [SailfishDevel] Binding weirdness on Jolla device after deploy with screen locked

Just to confirm this, I'm having same issues with my app. If I launch
it and put the screen off right away the application's screen is not
updated when I open it again from the cover. Have to swipe it back to
home and reopen it to get updated window.


--
Tero

2014/1/26  <christopher.lamb at thurweb.ch>:
> Hi Ove
>
> That's pretty much the behaviour I get, and the swipe to multitasking and
> back fixes things.
>
> The behaviour 1s 100% reproducible  when the screen is locked during deploy,
> and never occurs when deploying to an unlocked screen.
>
> That the problem to do with bindings is only a wild assumption on my part,
> it could be down to the screen not updating as you suggest.
>
> Grüsse
>
> Chris
>
>
> Zitat von "Ove Kåven" <ovek at arcticnet.no>:
>
>
>> Den 26. jan. 2014 13:42, skrev christopher.lamb at thurweb.ch:
>>>
>>> Hi all
>>>
>>> I have come across some weird behaviour on the Jolla:
>>>
>>> Bindings don't seem to work immediately after an app has deployed when
>>> the screen is locked.
>>
>>
>> Are you able to tell the difference between something like this, and the
>> more straightforward issue of the app display simply not updating? I
>> frequently experience the latter immediately after a deploy. If I click
>> anything, or try to use the pulley menu, I can hear the sounds and get the
>> console logs, but the display doesn't start updating before I swipe out to
>> the multitasking view and then reactivate it. Everything works otherwise.
>>
>> _______________________________________________
>> SailfishOS.org Devel mailing list
>>
>
>
>
> _______________________________________________
> SailfishOS.org Devel mailing list
_______________________________________________
SailfishOS.org Devel mailing list


More information about the Devel mailing list