[SailfishDevel] Cannot ssh to device in USB developer mode

dcaliste at free.fr dcaliste at free.fr
Thu Jan 23 14:01:08 UTC 2014

Hello list members,

   Sorry for asking this stupid question, but I can't connect to the device with
ssh when this one is connected via USB in developer mode. I can ssh to it when
connecting through WLAN though.

   What I'm doing:
- enable developer mode and set-up a password (this one is working since I can
connect through WLAN) ;
- plug-in USB cable from the computer and choose developer mode connection ;
- the settings page tell me that the address is affected to the USB
- I setup the computer to attribute to the interface
on usb0, statically (it's working since ping is responding).
- I ssh at this address with nemo as login, it's responding since it proposes to
add the hw key to the known host list, and then it's asking for the password,
but when I type it, I get permission denied. The password is alright since I can
ssh to the device when using WLAN connection.

   I've tried with a generated password from the interface also but no luck
neither. I've tried to find the logs of ssh, but was not able to find them,
before they were located in /var/log/auth, but not here. I've tried to look at
journalctl output but didn't found anything about rejected connection or ssh.
I've tried to google a bit, found the page http://elinux.org/Jolla but still get
permission denied.

   Can anyone help me on this, by pointing me where I can give a look to
understand what's happening, or by pointing out what I'm doing wrong.

Thanks in advance, and have a nice day,


More information about the Devel mailing list