[SailfishDevel] Device deployment problems (SSH connection dies)

christopher.lamb at thurweb.ch christopher.lamb at thurweb.ch
Mon Jan 13 08:13:29 UTC 2014


hi Jaako

As you have the problem with both Wifi and USB, it does sound like  
something to do with the device.

But for what it is worth, have you tried a different USB port?

Yesterday evening I was doing quite a bit of development with both my  
Jolla and my N9 in developer mode connected via USB at the same time.  
Mostly this worked, but I soon found that while the right-hand USB on  
my MacBookAir always worked reliably, the lefthand port was a bit iffy  
- sometimes I could connect, sometimes not, and would have to plug and  
unplug, swap cables and devices. It may also be that the lefthand port  
is more sensitive to particular USB cables.

Chris


Zitat von "Jaakko Koskenkorva" <jaakko at 11latoa.com>:

> I've been terribly frustrated by erratically working deployment to device
> from the SDK.
> It seems that the SSH connection dies frequently i.e. compile output shows:
>
> ssh: connect to host 192.168.2.250 port 22: Connection timed out
>
> rsync: connection unexpectedly closed (0 bytes received so far) [sender]
>
> rsync error: error in rsync protocol data stream (code 12) at io.c(226)
> [sender=3.1.0]
>
>
> ...and application output shows:
>
> SSH connection failed: Timeout waiting for reply from server.
>
> This usually happens after 1-2 deployments, after which device does not
> respond to ssh or ping.
> Things that can help in this situation (when using USB):
> 1) Reconnect USB cable
> 2) Increase timeout
> ...but I've yet to find a permanent solution.
> This also happens over WLAN with same symptoms, in this case re-connecting
> device to wifi router helps. Initially I thought that Ubuntu connection
> management was confused by the USB ethernet connection, but since WLAN has
> this problem too I'm thinking it's something in the device end?
>
> I'm using Ubuntu 13.10 64bit, latest SDK and v1.0.2.5 on device.
> Any ideas?
>
> --
> Jaakko Koskenkorva
> Ohjelmistokehittäjä | T:mi 11latoa
> jaakko at 11latoa.com
> http://11latoa.com
>





More information about the Devel mailing list