[SailfishDevel] AAC support

Jens Persson xerxes2 at gmail.com
Thu Jan 9 21:40:12 UTC 2014


I've been testing lots of audio formats in Sailfish (aac, dts, flac, mp3,
opus, alac, ac3, vorbis) and haven't noticed any issues so far. But that
somafm stream didn't work so I tested it on my desktop too where I keep an
old installation of gst-0.10 around and it bloody worked. It seems that
faad2 is a better fit for somafm so I added it to the gst-plugins-bad-extra
package on Openrepos.
https://openrepos.net/content/sailfishlib/gst-plugins-bad-extra

So now somafm works in Sailfish too and hopefully that codec doesn't screw
up something else. :)

Greets Jens



On Mon, Jan 6, 2014 at 12:46 AM, Damien Tardy-Panis <
damientardypanis at gmail.com> wrote:

> Hi all,
>
> I've been testing a bit different music file/stream formats on the phone
> Everything seems fine for flac/ogg/mp3, however I got some problems with
> AAC format
>
> I've tried several AAC/AAC-HE samples:
> - some found on the Internet
> - some converted from my collection
> - some streaming links
>
> And some files are played correctly, some not...
> It seems like no .aac file can be played and only some .m4a (with AAC) can
> (but still not all)
>
> Launching a AAC stream with gstreamer from command line like
> gst-launch-0.10 -v playbin2 uri=http://sfstream1.somafm.com:3000
> is telling me among other things
> Missing element: MPEG Audio decoder
>
> Can someone tell me what is going on?
> And what to do if possible (any extra plugin/package to install?...)
>
> Thanks a lot
>
> Damien
> _______________________________________________
> SailfishOS.org Devel mailing list
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.sailfishos.org/pipermail/devel/attachments/20140109/44816684/attachment.html>


More information about the Devel mailing list