[SailfishDevel] No inbox?

AL13N alien at rmail.be
Tue Jan 7 11:34:31 UTC 2014


Op dinsdag 7 januari 2014 10:32:04 schreef Valerio Valerio:
> Hi,
> 
> On 05/01/14 19:36, Chris Walker wrote:
> > On Thu, 2 Jan 2014 11:18:45 +0000
> > 
> > Chris Walker <cdw_nokiaqt at the-walker-household.co.uk> wrote:
> >> On Thu, 02 Jan 2014 12:50:08 +0200
> >> 
> >> Jonni Nakari <jonni at egarden.fi> wrote:
> >>> On 02.01.2014 12:23, Chris Walker wrote:
> >>>> As I appear to be the only one with this problem, it's plainly not
> >>>> something that should trouble the development team.
> >>> 
> >>> I had a similar problem when I tried adding my free Gmail account
> >>> using Microsoft Exchange account type. No errors were displayed when
> >>> creating the account or checking mail.
> >>> 
> >>> I might have also seen this problem when I mistyped some settings on
> >>> a imap type account, but not sure about that.
> >>> 
> >>> I suggest that you re-create and double check all you account's
> >>> settings. You might get some additional debug information by
> >>> enabling the developer mode and running "journalctl -f -a" as root
> >>> when first saving the account and when checking for new mail.
> >> 
> >> This is an IMAP account.
> >> 
> >> It is now declaring 'Problem with sync' so that does suggest a typo
> >> somewhere but I have checked and rechecked all the account
> >> information. I'm tempted to take a look at the accounts.db file to
> >> see what that holds.
> > 
> > I'm almost at the stage of throwing this thing away! It is *so*
> > frustrating to use that it beggars belief at times.
> > 
> > If I'm in the middle of setting up an email account and the screen
> > blanks (after 5 seconds and not the 30 seconds it's set to!), why when I
> > double tap to get back, does it revert to the home screen? I expect it
> > to be like most other equipment I've used, phones included and to go
> > back to where I left it.
> > 
> > But the real frustration is the email setting stuff. I *still* haven't
> > managed to get the thing to log into my IMAP account despite the fact
> > that I can do it on a Windows 7 machine, the linux machine, a
> > Blackberry Playbook and my N900 phone. They *all* show all the folders
> > on the IMAP account and yet the Jolla won't. I've created the account
> > countless times, both by ssh'ing in and doing it by the command line and
> > also by using the GUI. It always displays 'Problem with Sync'. So as I
> > also have an email account on the Playbook I used those settings and I
> > can see all the folders that are present on that account (also IMAP).
> > But having received an email into it, when I replied it wouldn't send. I
> > *think* that initially was a problem with my router for some reason so
> > having toggled the power to that I tried again. The message in the
> > outbox would not send despite using the same settings as the PB. So I
> > switched the settings on the Jolla to use the smtp server specified for
> > my landline (the same that the linux and Windows machine use) but it
> > still wouldn't send. I deleted the reply and recreated it and this time
> > it did go. To me, that implies that the message holds details of the
> > outgoing server and whatever I did, is never likely to make it send.
> > 
> > So some questions.
> > 
> > How can I reduce the number of accounts held in the sqlite database as
> > the number is already up to 7 and I only have 2 email accounts, one of
> > which doesn't work and the other one will be deleted?
> 
> Humm, can you clarify what are you trying to do ?
> 
> > Second question. Does the email hold details of the outgoing server
> > until it's sent?
> 
> Emails are associated with an account, so yes.
> 
> > [I do see messages in the terminal 'OfonoNetworkRegistration' there
> > was more to that but it's scrolled off screen too far to recall].
> > 
> > Third question and one that's been posed here before and that is, how
> > do I set the password for IMAP from the command line without using
> > push2mail and also, I would also like to be able to check the password.
> > Is there any way?
> 
> Not possible, passwords are stored in different database they can only
> be accessed via SSO apis.
> 
> I'm assuming you are running update2, right ?
> Not having inbox means that the email app could not connect to the
> server to retrieve folder list, so you get a error message, how did you
> configured the account, via the UI or command line ?
> What are the settings for your imap server ? port and encryption.

and... did you try IMAP protocol manually via telnet or openssl... or even 
with a wireshark checked what actually goes on?

does your server have insecure settings, such as plain login,anonymous on tls 
or whatnot? there are some peculiar imap servers out there... and while it may 
be a jolla bug or not... more info is required if you want this be to 
resolved...


More information about the Devel mailing list