[SailfishDevel] Using virtual machine's network (UDP BCast)

E.S. Rosenberg es.rosenberg+sailfishos.org at gmail.com
Sun Dec 28 10:24:21 UTC 2014


Though I haven't tried this with the SDK my experience with VirtualBox is
that you can change the network settings/type while the machine is already
running, so you could deploy etc. and only after the emulator is running
change the settings to be on a different network....

HTH,
Eli

2014-12-28 3:46 GMT+02:00 Niels Christian Ørgaard <ncothang at gmail.com>:

> Hi Sailfish Devs :)
>
> I'm wondering if any of you have any experience changing network-settings
> on the Emulator image for Sailfish.
>
> My headache is that my application needs to receive UDP Broadcast messages
> from the local (real) network, and with the 2 network interfaces being set
> to NAT and Internal Network, this seems to be, uhm, not quite possible.
>
> I have tried changing either of them to Bridged (first tried with the
> NAT'ed one, then later with the Internal Network one), but in both cases,
> QtCreator refuses to work with the Emulator:
> ----
>
> Error while building/deploying project Lightfish_qt (kit:
> MerSDK-SailfishOS-i486)
>
> When executing step 'Start Emulator'
> ----
> Even after changing them back, and comparing them to a clone of the
> original, I get the above error - seems to me that there is something more
> to the network settings, than exposed by Virtual Box.
>
> Testing the connection from QtCreator's preferences (manage devices ->
> Test Emulator), I am told that it is quite able to connect; it is merely
> during the deployment steps, that it fails miserably.
> The above is also the only thing I can see, relating to this failure.
>
>
> Any insights into getting this to work, where I can have the emulator on a
> bridged network, receiving packages from other devices, and actually reach
> it from QtCreator, would be most welcome.
> Steps on how to get from the point where QtCreator SAYS it can communicate
> with the Emulator, to the point where it actually can, also very welcome.
>
>
> Note: Due to my phone managing to take out QtCreator earlier tonight, I'm
> on a completely clean install of the SDK (incl deleting the files in
> .config) - but if I need to, I'll re-install a few more times.
> (the ca 20-second crash-restart loop QtCreator got itself into were
> interesting, but quickly tiresome)
>
> Also: Since my Jolla Phone is effectively dead following the recent
> "update", I am having to rely on the Emulator to get any work done - thus,
> no need to suggest that I test using a real device: a functional one is
> currently not available :(
>
>
> In advance, thank you for any and all help,
> Niels Chr. Ørgaard
> Belgium
>
> _______________________________________________
> SailfishOS.org Devel mailing list
> To unsubscribe, please send a mail to
> devel-unsubscribe at lists.sailfishos.org
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.sailfishos.org/pipermail/devel/attachments/20141228/96ee8468/attachment-0001.html>


More information about the Devel mailing list