[SailfishDevel] Installation trouble with the SDK

Luciano Montanaro mikelima at gmail.com
Thu Dec 11 09:21:16 UTC 2014

On Thu, Dec 11, 2014 at 10:06 AM,  <kim at foder.dk> wrote:
>> On 10. des. 2014 10:41, kim at foder.dk wrote:
>> > I have had this problem since I upgraded Ubuntu to 14.10, and have recently come to the conclusion that the problem probably is entropy.
>> >
>> > A test has shown that the entropy pool always is extremely low (about 1000 with heavy disk access, less than 800 otherwise)
>> >
>> > I have tried to generate more entropy by starting programs with heavy disk or net acces, and fidling with the mouse, but the installation still hangs at 76%, and after a short while everything on the desktop freezes, even the mouse.
>> >
>> > The only way to get out of it is a long press on the power button.
>> These symptoms do not sound like it has anything at all to do with
>> entropy. I don't know where you could have gotten that idea.

So you did replicate my hang.

> The fact that the installation hangs (and freezes the desktop) at "Generating keys" and the entropy pool is very low, made me believe there was a connection.

It looked the same to me. But then, an ssh-keygen would have the same
problem, and it did not.

>> The symptoms sound more like what would happen if there was too much
>> I/O, too many programs running, too much memory used, and perhaps too
>> much swap space: the system would start swapping so heavily it would
>> become totally unresponsive.
> This is of course the first things I checked: Lots of memory free (> 2G), no disk access at all when installation hangs, 2 programs running system-monitor & installation.

Confirming, from my side. My laptop has 6GB RAM, and besides, there
was not much disk activity a tthe moment of the hang.
I think the merssh command is not able to complete. My question is...
shouldn't there be a virtualbox "mersdk" instance available before
invoking the merssh command? Because the virtualbox manager does not
show a configuration for it.

Is there a guide to set it up manually? The .vdi is installed anyway,
I might be able to complete the installation manually (or at least
build my projects with the command line tools) if the virtual box
machine is configured correctly.

I tried creating a machine on my own with the mersdk.vdi, and it
boots... but I do not know how to set it up so that i can connect to
it/share the source partition.

Best regards,

>> _______________________________________________
>> SailfishOS.org Devel mailing list
>> To unsubscribe, please send a mail to devel-unsubscribe at lists.sailfishos.org
> _______________________________________________
> SailfishOS.org Devel mailing list
> To unsubscribe, please send a mail to devel-unsubscribe at lists.sailfishos.org

Luciano Montanaro

Anyone who is capable of getting themselves made President should on
no account be allowed to do the job. -- Douglas Adams

More information about the Devel mailing list