[SailfishDevel] No RPM built ?

Kimmo Lindholm Kimmo.Lindholm at eke.fi
Tue Dec 2 20:00:47 UTC 2014


Hi,

https://gitorious.org/mkpokerplanning/mkpokerplanning/ ?

Try to close project, delete .pro.user, delete build- dir, reopen project, Reconfigure it.
then hit deploy.

deployed for me (after adding / after %{_datadir} in yaml)
- '%{_datadir}/harbour-mkpokerplanning'
- '%{_datadir}/harbour-mkpokerplanning/languages'
- '%{_datadir}/icons/hicolor/86x86/apps'
- '%{_datadir}/applications'

-kimmo

From: devel-bounces at lists.sailfishos.org [mailto:devel-bounces at lists.sailfishos.org] On Behalf Of Franck Routier (perso)
Sent: Tuesday, December 02, 2014 8:36 PM
To: devel at lists.sailfishos.org
Subject: [SailfishDevel] No RPM built ?

Hi,

I am trying to package my app as a RPM, but I don't get any RPM.

The target I choose is  "MerSDK-SailfishOS-armv7hl / Release / Deploy By Building an RPM Package."

The console output is :



19:28:58: Running steps for project harbour-mkpokerplanning...

19:28:58: Start SDK: Starting "MerSDK" virtual machine...

19:29:07: Starting: "/home/franck/.config/SailfishBeta1/mer-sdk-tools/MerSDK/SailfishOS-armv7hl/qmake" /home/franck/devel/qt-mobile/harbour-mkpokerplanning/harbour-mkpokerplanning.pro -r -spec linux-g++



Building target platforms: armv7hl-meego-linux

Building for target armv7hl-meego-linux

Executing(%build): /bin/sh -e /var/tmp/rpm-tmp.qeXxnF

19:29:11: The process "/home/franck/.config/SailfishBeta1/mer-sdk-tools/MerSDK/SailfishOS-armv7hl/qmake" exited normally.

19:29:11: Starting: "/home/franck/.config/SailfishBeta1/mer-sdk-tools/MerSDK/SailfishOS-armv7hl/make"

Building target platforms: armv7hl-meego-linux

Building for target armv7hl-meego-linux

Executing(%build): /bin/sh -e /var/tmp/rpm-tmp.0QhjVX

make: Nothing to be done for `first'.

19:29:12: The process "/home/franck/.config/SailfishBeta1/mer-sdk-tools/MerSDK/SailfishOS-armv7hl/make" exited normally.

19:29:12: Elapsed time: 00:14.

In my build-harbour-mkpokerplanning-MerSDK_SailfishOS_armv7hl-Release directory, I have no rpm subdir, only these files:

harbour-mkpokerplanning    Makefile        qrc_images.o
harbour-mkpokerplanning.o  qrc_images.cpp

So, I must be mssing something, but... what ?

thanks in advance,
Franck
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.sailfishos.org/pipermail/devel/attachments/20141202/83adac0f/attachment-0001.html>


More information about the Devel mailing list