[SailfishDevel] Can't start VMs (Connection refused)

Canol Gökel canol at canol.info
Sat Jul 27 21:55:46 UTC 2013


Okay, I installed a newer 32-bit version of my distro (was using 64-bit before) and this time I got connection refused message only from emulator and not from mersdk. I replaced all the ssh keys in mersdk and emulator folders with a new one just like you said and now it works.

Thanks.

Canol

Date: Sat, 27 Jul 2013 18:44:41 +0200
From: superpelican at zoho.com
To: devel at lists.sailfishos.org
Subject: Re: [SailfishDevel] Can't start VMs (Connection refused)


  
    
  
  
    Hello,

      

      I'm also having this problem very often.

      You can fix it by regenerate the ssh rsa keys, that the SDK uses
      to authenticate with the Mer VM ssh connection and replacing the
      old public key in the authorized_keys file with the new public rsa
      key in $HOME/Sailfish_SDK_install_dir/emulator/ssh/nemo/ and
      $HOME/Sailfish_SDK_install_dir/emulator/ssh/root. You can do this
      by opening a shell/terminal and running the "ssh-keygen -t rsa"
      command and then when it asks where to save the key pair enter
      "$HOME/.ssh/mer-qt-creator-rsa" and when it asks you whether or
      not to overwrite the existing key pair with the same name enter
      "y" (yes). Now you have to navigate to the (hidden) $HOME/.ssh
      directory (you can toggle "show hidden files" with ctrl+h in
      "Files/Nautilus"(GNOME), alt+. in "Dolphin"(KDE) and ctrl+. in
      "Thunar"(XFCE) or by checking the "show hidden ..." option in the
      view menu in all file managers if I recall correctly). Now open
      the mer-qt-creator-rsa.pub file with a random text editor and copy
      all it's contents with ctrl+a and ctrl+c.

      then navigate to the
      $HOME/Sailfish_SDK_install_dir/emulator/ssh/root and replace the
      contents of the authorized_keys file with the contents you just
      copied from the mer-qt-creator-rsa.pub file. Do the same with the
      authorized_keys file in
      $HOME/Sailfish_SDK_install_dir/emulator/ssh/nemo.

      

      This should fix the connection refused issue. I've noticed that it
      seems that when you close the VMs in another way then clicking the
      "stop SDK" and "stop emulator" buttons you often get the
      "connection refused" error the next time you start the Sailfish
      SDK. Possibly this has something to do with corruption/damaging of
      the keys when abruptly ending the ssh connection between the
      emulator/Mer SDK and Qt Creator/your host system. Although I've
      haven't got any evidence for this ;)

      

      I hope this is helpful,

      

      Superpelican

      

      

      On 07/27/2013 12:29 PM, Canol Gökel wrote:

    
    
      
      Hello,

        

        I wanted to try Sailfish SDK. Installed VirtualBox and then the
        SDK. The IDE started, I created the hello world app. But when I
        tried to run it, it gave me the error: "MerSDK: Connection
        refused". I tried to manually start the VMs using the buttons on
        left panel but it gave the same error.

        

        What might be the problem?

      
      

      
      

      _______________________________________________
SailfishOS.org Devel mailing list
    
    

  


_______________________________________________
SailfishOS.org Devel mailing list 		 	   		  
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.sailfishos.org/pipermail/devel/attachments/20130728/a0289de3/attachment.html>


More information about the Devel mailing list