[SailfishDevel] FolderListModel errors

Simba Chilimanzi onias_c at yahoo.com
Wed Aug 21 02:06:44 UTC 2013

Can you please remove me from this list?

On 21/08/13 11:55 P S wrote:

I uninstalled the qt4 folderlistmodel in the Sailfish OS emulator, and both deploying as binary or rpm still gave the same error. Then I reinstalled the Sailfish OS SDK, added the requirement for qt5-qtdeclarative-import-folderlistmodel to yaml and deployed as rpm. Now it works fine using rpm or binary. Not sure what went wrong the first time.

Thanks for the input.



On Mon, Aug 19, 2013 at 11:19 PM, Jonni Rainisto <jonni.rainisto at jollamobile.com> wrote:

import Qt.labs.folderlistmodel 1.0
works for me at least, only thing that I added was the line in spec file (or in yaml) and installed the rpm that I created (which pulled the requirements in).
Requires:   qt5-qtdeclarative-import-folderlistmodel

Most likely you just want to uninstall everything releated to qt4 and make sure that qt5-qtdeclarative-import-folderlistmodel is installed in right VM.

re, Jonni

From: devel-bounces at lists.sailfishos.org [devel-bounces at lists.sailfishos.org] on behalf of P S [psappsdev at gmail.com]
Sent: Tuesday, August 20, 2013 8:54 AM
To: devel at lists.sailfishos.org
Subject: [SailfishDevel] FolderListModel errors


I am using the QML FolderListModel in my application. Using zypper, I installed libqtdeclarative4-folderlistmodel but it gave the following error:  
module "Qt.labs.folderlistmodel" is not installed

Since the new SDK offers some Qt5 and QtQuick2 support, I then also installed qt5-qtdeclarative-import-folderlistmodel on the emulator, but I keep getting the same error.

Any suggestions?


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.sailfishos.org/pipermail/devel/attachments/20130821/5db403a8/attachment.html>

More information about the Devel mailing list