[SailfishDevel] Wrong Qt version in package manager description?

Carsten Munk carsten.munk at jollamobile.com
Fri Aug 2 06:19:07 UTC 2013


On 08/02/2013 02:24 AM, Ketil Kvifte wrote:
> Have you been working too fast? To me it looks like the package manager
> think it have Qt-5.0.2 installed, while the libraries themselves say
> they come from the Qt-5.1.0 release. It looks like you updated the
> sources without updating the rpm-spec file. I am not very familiar with
> rpm-packaging though so please correct me if I am wrong. I just want to
> let you know in order to prevent confusion later.
Hi,

On the contrary :) Due to upgradeability reasons and 5.1.0 not being 
fully released at the time, we have one of the RC's (hence 
5.0.2gitsomething). When you upgrade, you can't go 5.1.0something to 5.1.0.

Sailfish will be following 5.1 'release' branch for qt modules for most 
part and we changed soon after the SDK snapshot to 5.1.0 versioning as 
5.1.0 got released.

When you see <version> git <something> it means some git version past 
<version>

/Carsten
>
> [root at SailfishEmul nemo]# rpm -q qt5-qtcore
> qt5-qtcore-5.0.2git13604.9095210-1.5.2.i486
> [root at SailfishEmul nemo]# /usr/lib/libQt5Core.so.5
> This is the QtCore library version 5.1.0
> Copyright (C) 2013 Digia Plc and/or its subsidiary(-ies).
> Contact: http://www.qt-project.org/legal
>
> Build date:          2013-07-13
> Installation prefix: /usr
> Library path:        /usr/lib
> Include path:        /usr/include/qt5
> Processor features:  sse2 sse3 ssse3
>
> Ketil Kvifte
> _______________________________________________
> SailfishOS.org Devel mailing list



More information about the Devel mailing list