<div dir="ltr">Should zypper or PackageKit rather be used in Sailfish?<br></div><div class="gmail_extra"><br clear="all"><div><div>--</div>Marcin<br></div>
<br><br><div class="gmail_quote">2013/10/26 Jarko Vihriala <span dir="ltr"><<a href="mailto:jarko.vihriala@jolla.com" target="_blank">jarko.vihriala@jolla.com</a>></span><br><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">






<div>
<div style="direction:ltr;font-size:10pt;font-family:Tahoma">Hello all,<br>
<br>
We discovered that PackageKit that is used in our emulator does not automatically refresh repositories so if your rpmbuild requires additional stuff to be pulled to emulator - it will eventually fail.
<div><a name="141f4268ab1e88be_lnkB" href="https://connect.emailsrvr.com/owa/?ae=Item&a=New&t=IPM.Note&cc=MTQuMy4xNTguMSxlbi1VUyw0Mjk0OTY3Mjk1LEhUTUwsMCww&pspid=_1382779855830_872310806#" target="_blank"><span></span></a></div>


<br>
Good news is that quickfix is in the works and should be out next week. But before that is applicable this workaround needs to be done:<br>
1. login to emulator (best is to press ctrl-<f-keys> on emulator's window to get login prompt) as root. On my ubuntu f2 seems to cut it.<br>
2. refresh repos with 'pkcon refresh'<br>
optionally then: <br>
3. test that repos got refreshed (do f.ex 'pkcon search sensorfw-qt5-devel') if you see stuff like 'Available..' then your emulator has updated lists and you're good to go. If not - run 2) again.<br>
<br>
Sorry for the extra trouble, we'll publish new emulator soon and it is delivered via SDK update (you'll get notice in Qt Creator's UI on that).<br>
<br>
thanks, Jarko<br>
<br>
</div>
</div>

<br>_______________________________________________<br>
SailfishOS.org Devel mailing list<br></blockquote></div><br></div>