[SailfishDevel] SDK again, again...

Thomas Tanghus thomas at tanghus.net
Fri Nov 22 21:28:38 UTC 2019


Sorry if this mail comes several times. Had some problems with kmail.

On Monday, 18 November 2019 07.34.25 CET you wrote:
> Hi Thomas,
> 
> The error messages in the tool tip shown when the *-armv7hl kit is hovered
> tell you the device selected in kit configuration is architecture
> incompatible with the kit. The kit supports armv7hl devices while the
> device (Sailfish OS Emulator) is an x86 device. You can still use the kit
> to build RPM packages for the armv7hl architecture, you will just not be
> able to run those directly from Qt Creator. For that you need to provide
> a hardware device with that architecture and configure the kit to use
> that instead of the emulator. Use the *- i486 kit if you want to run your
> software under the Sailfish OS Emulator.

Thanks a lot for the detailed explanation, and sorry for the late reply. I 
got access to my desktop pc, and got side-tracked elsewhere.

I will try to install again on my laptop. I was sure I had set the kit to 
arm and the device to run on to be my phone, but you're right that it 
doesn't look like it in the screenshot.

> The installation log currently contains information that is mostly useful
> to someone with knowledge of SDK installer internals. An error message
> appearing there is not necessary meaning something wrong. The installer
> would complain verbosely if an installation error really occurred.
 
Good to know, I'll focus on the relevant parts.

-- 

/Thomas




More information about the Devel mailing list