[SailfishDevel] Error starting build Engine

Martin Kampas martin.kampas at jolla.com
Tue Aug 6 07:41:40 UTC 2019


Hi Iosif,

> Under Win10 during installation I get the following error: SSH timeout.
> 
> If I press retry I continuously get the same error. If I press ignore I get
> the same error for all targets. At some time the installation succeeds, but
> cannot start the build engine

The installation is likely to be broken, but still it may be in a state that can be used to debug the 
connection issue more conveniently that during the installation, so let's continue with that.

Could you please try if you can SSH to the build engine from command line using something like 
this from the Git Bash? (Start the VM first, using VBox interface.)

ssh -p 2222 -i /c/SailfishOS/vmshare/ssh/private_keys/engine/mersdk mersdk at localhost

If this fails, try with one or more '-v' to increase SSH's verbosity.

Next, could you please collect the debug output from Qt Creator? You should be able to enable 
the necessary logging categories by creating the file C:\SailfishOS\bin\QtProject\qtlogging.ini 
with the following content:

[Rules]
mer.vms*.debug=true
qtc.ssh.debug=true

(Check https://doc.qt.io/qt-5/qloggingcategory.html#configuring-categories for more info)

AFAIK on Windows you will also need to run Qt Creator under debugger in order to see the 
console output. I use WinDbg for that, in File -> Open Executable choose C:
\SailfishOS\bin\qtcreator.exe and also file Start directory in the same dialog as C:\SailfishOS\bin 
(important!).

BR,
Martin

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.sailfishos.org/pipermail/devel/attachments/20190806/8bb3d1b8/attachment.html>


More information about the Devel mailing list