[SailfishDevel] QtLocstion (5.6) | Re: SDK version 1701 (2.1.0) is released to Early Access

Pekka Vuorela pekka.vuorela at jolla.com
Mon Feb 13 10:04:46 UTC 2017


On la, 2017-02-11 at 13:58 +0100, micu wrote:

> >    * Qt 5.6 module imports allowed
> 
> When I try out the new SDK with my app, I still get: 
> 
> > 
> > Requires
> > ========
> > ERROR [libQt5Location.so.5] Cannot require shared library:
> > 'libQt5Location.so.5' ERROR [qt5-plugin-geoservices-osm] Dependency
> > not
> > allowed
> > ERROR [qt5-qtdeclarative-import-location] Dependency not allowed
> > ERROR [qt5-qtlocation] Dependency not allowed
> > INFO [harbour-berlin-vegan] Please see our FAQ here:
> > https://harbour.jolla.com/faq#2.6.0 how to use
> > '__provides_exclude_from'
> > and '__requires_exclude' .spec file to avoid that FAILED
> 
> Neither can I find 5.6 versioned QtLocation packages on the device
> (via pkcon search) with the new Sailfish OS 2.1.0.9 release.
> 
> I assume that means that QtLocation (5.6) will still not be part of
> 2.1.0.9?
> 
> Can we expect this for any future release soon?
> Would be very cool to have it :).

Yeah, unfortunately not all the Qt packages were yet updated. Hoping
we'll soon get QtLocation handled too.



More information about the Devel mailing list