[SailfishDevel] Deploy as RPM package vs copying binaries

Martin Kampas martin.kampas at jolla.com
Thu Mar 24 07:30:16 UTC 2016


Hi Dylan,

could you describe step by step your procedure from unpacking the source archive from your original message to installing the resulting RPM package? And attach the output of 'rpm -qlp Sailfinder-0.1-1.armv7hl.rpm'?

Martin

________________________________
From: Dylan Van Assche [dylan.van.assche at protonmail.com]
Sent: Wednesday, March 23, 2016 12:19 PM
To: Martin Kampas
Subject: Re: [SailfishDevel] Deploy as RPM package vs copying binaries

Hi,

No it was, I think it's a bug in QT creator...
Time for an update?

Dylan


Sent from ProtonMail mobile



-------- Original Message --------
On 10:15, 23 Mar 2016, Martin Kampas wrote:

Hello Dylan,

does this still persist? I tried to build and use RPMs from your sources and it worked.

BR,
Martin

________________________________
From: devel-bounces at lists.sailfishos.org [devel-bounces at lists.sailfishos.org] on behalf of Dylan Van Assche [dylan.van.assche at protonmail.com]
Sent: Thursday, March 17, 2016 10:30 PM
To: Sailfish OS Developers
Subject: [SailfishDevel] Deploy as RPM package vs copying binaries

Dear developers,

I just finished my app and I'm ready to pack it into an RPM.
I used the 'copying binaries' method when I developed it and that worked fine since it copies all the files piece by piece to my Jolla.
However when I use 'deploy as RPM package' method I'm getting in trouble with the dependencies. I expected that I have to change my .pro file to include my dependencies, which I did.
QT creator shows in the project tree those files on 'Other files'.
I haven't changed the .yaml file since all my dependencies are in the 'qml' folder which is already covered by the .yaml file (as far as I understand it).

When I try to deploy the RPM package I get this error:


[W] unknown:-1 - file:///usr/share/Sailfinder/qml/Sailfinder.qml: File not found

The app can't find the page Sailfinder.qml (which is the page that calls the firstPage).
I'm not experienced with QT since it's my first app for Sailfish OS, so I don't know what to do (I already read the 'packaging apps' tutorial on sailfishos.org)...
Here's a link to my project as a ZIP file since it's too big to send it as an attachment to the mailing list: mega.nz/#!Xt0QlCbJ!kvPIGNriIVEtQ9cg1d1qDFNDz65II_XjtRSwjSdWE9M<https://mega.nz/#!Xt0QlCbJ!kvPIGNriIVEtQ9cg1d1qDFNDz65II_XjtRSwjSdWE9M>
I hope somebody can help?

Regards,
Dylan

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.sailfishos.org/pipermail/devel/attachments/20160324/9d7fbfc4/attachment.html>


More information about the Devel mailing list