[SailfishDevel] Compilation error

Zoltán Lutor zoltan.lutor at gmail.com
Thu Jan 7 21:05:38 UTC 2016


ooo! Is it something new? Some time ago there was VM for ARM stuffs, if I
remember correctly...

Long story in short: I should test on emulator with i486 package but build
app for both x86 and armv7 and upload both of packages to Harbour?

Thx

2016-01-07 21:14 GMT+01:00 Andrey Kozhevnikov <coderusinbox at gmail.com>:

> emulator is only i486 based.
>
> ------ Исходное сообщение ------
> От: "Zoltán Lutor" <zoltan.lutor at gmail.com>
> Кому: "Andrey Kozhevnikov" <coderusinbox at gmail.com>; "Sailfish OS
> Developers" <devel at lists.sailfishos.org>
> Отправлено: 08.01.2016 0:50:16
> Тема: Re: [SailfishDevel] Compilation error
>
>
> If so the error message is totaly valid... :)
>
> The question is why did it so because I selected ARM target:
> [image: Szövegközi kép 1]
>
> Should/can I change emulator that it is ARM based? By default it is x86
> based...
>
> I'm sorry if question is totally lame - I've created my very first
> Sailfish app two days ago... ;)
>
> Thx.
>
> 2016-01-07 18:36 GMT+01:00 Andrey Kozhevnikov <coderusinbox at gmail.com>:
>
>> it builds okay but failed to install arm package on i486 target
>>
>> ------ Исходное сообщение ------
>> От: "Zoltán Lutor" <zoltan.lutor at gmail.com>
>> Кому: "Sailfish OS Developers" <devel at lists.sailfishos.org>
>> Отправлено: 07.01.2016 23:34:11
>> Тема: [SailfishDevel] Compilation error
>>
>>
>> I've tried to build my project and it is OK for x86 target but building
>> failed for armv7:
>>
>> Error: /home/nemo/RPMS/harbour-iqchallengesliderpro-1.0-1.armv7hl.rpm has
>> wrong architecture: armv7hl
>>
>> Finished transaction (status=2, runtime=4ms)
>>
>> Deploy failed
>>
>> 18:29:13: The process
>> "F:\SDK\SailfishOS\settings\SailfishBeta7\mer-sdk-tools\MerSDK\SailfishOS-armv7hl\deploy.cmd"
>> exited with code 1.
>>
>> Error while building/deploying project harbour-iqchallengesliderpro (kit:
>> MerSDK-SailfishOS-armv7hl)
>>
>> When executing step "RPM"
>>
>>
>> Any idea what I did wrong?
>>
>>
>>
>>
>> _______________________________________________
>> SailfishOS.org Devel mailing list
>> To unsubscribe, please send a mail to
>> devel-unsubscribe at lists.sailfishos.org
>>
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.sailfishos.org/pipermail/devel/attachments/20160107/76cf70b9/attachment-0001.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: image.png
Type: image/png
Size: 69849 bytes
Desc: not available
URL: <https://lists.sailfishos.org/pipermail/devel/attachments/20160107/76cf70b9/attachment-0001.png>


More information about the Devel mailing list