[SailfishDevel] Harbour libssl and libcrypto

Andrey Kozhevnikov coderusinbox at gmail.com
Mon Jan 19 15:29:04 UTC 2015


Also i can't find usage of QCA in your project code. And haveclip-core 
submodule is set to some private repository.

19.01.2015 20:20, Jakub Skokan пишет:
> Hello,
>
> has anyone succeeded in publishing an app requiring libssl in Harbour?
>
> Even though the RPM validator tool in Qt Creator says my package is ok,
> when I try to upload it to Harbour, it fails:
>
> No OS version and packages satisfy package requirements:
> Requirement libcrypto.so.10 not available
> Requirement libcrypto.so.10(libcrypto.so.10) not available
> Requirement libssl.so.10 not available
> Requirement libssl.so.10(libssl.so.10) not available
>
> Those are the exact libraries that are supposed to be whitelisted, so
> I'm at a loss... When installed on the phone running latest OS version
> using Qt Creator (deploy by RPM), it works as expected.
>
> For reference, the source code of the app and resulting RPM is here:
>
> https://github.com/aither64/haveclip-mobile
>
> I'm shipping a private library (QCA), which requires libssl, don't know
> if that may be the problem or why.
>
> Thanks for any hints.
>
> Jakub
> _______________________________________________
> SailfishOS.org Devel mailing list
> To unsubscribe, please send a mail to devel-unsubscribe at lists.sailfishos.org

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.sailfishos.org/pipermail/devel/attachments/20150119/6d70baad/attachment.html>


More information about the Devel mailing list