[SailfishDevel] Error starting VM

kim at foder.dk kim at foder.dk
Mon Feb 16 10:16:53 UTC 2015


> This application failed to start because it could not find or load the
> Qt platform plugin "xcb".

I had this problem too, I think I had to disable something on the SDK in VirtualBox, I'm not sure but I think it was VT-x/AMD-V under system / acceleration.

I'm at work right now, but I'll check it when I get home tonight.

/Kim

> On Sun, 15 Feb 2015 18:42:25 +0000
> Cathal Garvey <cathalgarvey at cathalgarvey.me> wrote:
> 
> > Hi all,
> > I'd like to get started playing with SFOS SDK with a view to getting
> > a phone and developing for Glacier and Sailfish. I wanted to play a
> > bit with the VM that comes with the SDK, but am getting bugs..
> > 
> > So, I clicked the start-emulator button in the QTCreator SDK, and I
> > get the following startup messages, then it freezes and goes no
> > further (as in, black screen with white monospace font saying the
> > below):
> > 
> > [    0.000000] tsc: Fast TSC calibration failed
> > systemd-fsck[62]: system: clean, 23245/262144 files, 244244/1048575
> > blocks [   12.297269] piix4_smbus 0000:00:07.0: SMBus base address 
> > uninitialized - upgrade BIOS or use force_addr=0xaddr
> > 
> > I could just try what's suggested and add the force_addr boot option 
> > (where?) but isn't this supposed to just work?
> > 
> > I'm using virtualbox 4.3.22 as installed from virtualbox.org "generic 
> > linux 64 bit" on Linux Mint Debian Edition 64 bit; loosely Debian
> > Jesse but about a year out of date (thanks Linux Mint..).
> > 
> > Any help in getting this booting to a home screen appreciated, would 
> > love to play with this and see about developing some simple demo apps.
> 
> I'm getting the same error although both the emulator and build machine
> are shown to be running by the icons at the bottom left of Creator.
> 
> If I persevere, then I get this error from Creator in 'Application
> Output' :-
> 
> QML debugging is enabled. Only use this in a safe environment.
> This application failed to start because it could not find or load the
> Qt platform plugin "xcb".
> 
> Available platform plugins are: eglfs, minimal, wayland-egl, wayland.
> 
> Reinstalling the application may fix this problem.
> bash: line 1:   774 Aborted                 DISPLAY=:0.0
> QT_NO_JOURNALD_LOG=1 /opt/sdk/harbour-beertent/usr/bin/harbour-beertent
> Application finished with exit code 134.
> 
> 
> _______________________________________________
> SailfishOS.org Devel mailing list
> To unsubscribe, please send a mail to devel-unsubscribe at lists.sailfishos.org


More information about the Devel mailing list