[SailfishDevel] [Sailfish IDE] Can't run app in Debug mode anymore

Benoît HERVIER khertan at khertan.net
Tue Jan 21 15:18:59 UTC 2014


It was working in Alpha2 SDK, and is broken in Alpha3 SDK ... :)

---
Benoît HERVIER - http://khertan.net/

Le 2014-01-21 16:14, winfried.dobbe at xmsnet.nl a écrit :
> Are you sure it worked some weeks ago? Because as far as I know, 
> debugging
> has so far never worked, not on the emulator nor on the target.
> 
> I recently encountered the same issue and on IRC some sailors replied 
> that
> it's currently a known issue that will be fixed in a future SDK update.
> 
> regards,
> 
> Winfried
> 
> 
>> 
>> 
>> 
>> 
>> 
>> 
>> Hello,
>> This week-end, I wanted to investigate some segfault (easily 
>> reproducible,
>> see here:
>> https://lists.sailfishos.org/pipermail/devel/2013-December/001707.html 
>> )
>> And for some reason, I found out that I am not able to run an app in 
>> Debug
>> anymore :/
>> Few weeks ago it worked, but now, the Run Debug command just get stuck
>> forever at the "Lauching" stage (after deployment)You can find below 
>> the
>> last lines of the debug logs (I don't know why copy/past add a "d" at 
>> the
>> beginning of each line)As anybody encountered the same issue? Any idea 
>> of
>> what I can do?
>> 
>> ps: I tried to uninstall/reinstall the SDK and recreate an application
>> from scratch, but it doesn't help.pps: If you want the very simple
>> segfaulting application described in the link above, I've put it here:
>> http://sthocs.free.fr/sailfish/Hello-0.1-1.armv7hl.rpm. Click on any 
>> Item
>> to go to the second page and pull back to the first page: segfault.
>> 
>> Thank you,Sylvain.
>> 
>> 
>> dState changed from DebuggerNotReady(0) to EngineSetupRequested(1)
>> dQUEUE: SETUP ENGINE
>> dNOTE: REQUEST REMOTE SETUP
>> dCALL: SETUP ENGINE
>> dEXAMINING
>> C:/Users/Sylvain/Sailfish/build-Hello-MerSDK_SailfishOS_i486_x86-Debug/Hello
>> dELF SECTIONS:  .interp .note.ABI-tag .note.gnu.build-id .gnu.hash 
>> .dynsym
>> .dynstr .gnu.version .gnu.version_r .rel.dyn .rel.plt .init .plt .text
>> .fini .rodata .eh_frame_hdr .eh_frame .init_array .ctors .dtors .jcr
>> .dynamic .got .got.plt .data .bss .comment .debug_aranges .debug_info
>> .debug_abbrev .debug_line .debug_str .debug_ranges .debug_types 
>> .gdb_index
>> .shstrtab .symtab .strtab
>> dNOTE: REQUEST REMOTE SETUP
>> dCALL: SETUP ENGINE
>> dEXAMINING
>> C:/Users/Sylvain/Sailfish/build-Hello-MerSDK_SailfishOS_i486_x86-Debug/Hello
>> dELF SECTIONS:  .interp .note.ABI-tag .note.gnu.build-id .gnu.hash 
>> .dynsym
>> .dynstr .gnu.version .gnu.version_r .rel.dyn .rel.plt .init .plt .text
>> .fini .rodata .eh_frame_hdr .eh_frame .init_array .ctors .dtors .jcr
>> .dynamic .got .got.plt .data .bss .comment .debug_aranges .debug_info
>> .debug_abbrev .debug_line .debug_str .debug_ranges .debug_types 
>> .gdb_index
>> .shstrtab .symtab .strtab
>> dTRYING TO START ADAPTER
>> dNOTE: REQUEST REMOTE SETUP
>> 
>> 
>>  		 	   		  _______________________________________________
>> SailfishOS.org Devel mailing list
> 
> 
> _______________________________________________
> SailfishOS.org Devel mailing list


More information about the Devel mailing list