[SailfishDevel] QStandardPaths not working when app is run from Launcher

Sylvain B. sthocs at hotmail.com
Sun Jan 19 13:34:59 UTC 2014


Hey,
My app did not want to read the some cached content it was supposed to have written in QStandardPaths::CacheLocation.
To understand why, I tried to run it from the terminal, and... everything is working fine.
Since we don't have logs when we run the app directly from Launcher, I updated it to display some logs directly in the UI and I figured out that, when the app is run from the Launcher on the actual device (it's ok on the emulator), QStandardPaths does not work correctly:

QStandardPaths::CacheLocation returns /home/nemo/.cache/mdeclarativecache_pre_initialized_qapplication-XXXXX

XXXXX is a random number, so each time I run my app, it creates a new one.
When run from terminal, QStandardPaths::CacheLocation correctly returns /home/nemo/.cache/

I tried with QStandardPaths::DataLocation but it's the same, I get /home/nemo/.local/share/AppName/mdeclarativecache_pre_initialized_qapplication-XXXXX

So for the moment, I temporarily hardcoded /home/nemo/.cache/

Thanks!
Sylvain.
 		 	   		  
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.sailfishos.org/pipermail/devel/attachments/20140119/5745696b/attachment.html>


More information about the Devel mailing list