[SailfishDevel] MerSDK VM - "src" folder change (under Windows) not possible

Juha Kallioinen juha.kallioinen at jolla.com
Wed Jan 15 16:11:06 UTC 2014

Hi Simon,

if you want to get rid of your old settings, clean the Qt creator config 
directory after uninstallation (be sure to close qt creator before 
cleaning too).

This is mentioned in the known issues page:


* If you want to change settings such as SDK installation location or 
additional source code location path, you need to remove SDK 
installation and manually delete the config file directory 
SailfishAlpha3 (in Windows it's under 
C:\Users\<username>\AppData\Roaming\SailfishAlpha3 and in other systems 
it's under $HOME/.config/SailfishAlpha3) and then re-install SDK.

Best regards,

On 15.01.2014 18:07, Simon Bolek wrote:
> Short update. I finally removed SailfishOS SDK and installed it again.
> I used ccleaner to clean registry etc.
> Installed SDK again AND... still the same :((( (crying)
> QtCreator sees the old settings. (see screenshots)
> HELP! Is there something obvious i'm missing?
> br
> simon ;-)
> On Tue, Jan 14, 2014 at 4:14 PM, Simon Bolek 
> <simon.bolek at googlemail.com <mailto:simon.bolek at googlemail.com>> wrote:
>     hi,
>     I have a difficulty in changing src shared folder for VM MerSDK in
>     QtCreator. It seems impossible right now.
>     Working on windows 7 with the latest SailfishOS installed.
>     While installing I set, stupid me, Project Folder to:
>     C:/path1/path1;C:/path2/path2
>     thinking QtCreator would understand both. After that started a
>     project and noticed that QtCreator  does not accept that.
>     Under
>     Tools->Options->Mer: MerSDK-"Shared Folders"-"src"
>     I see
>     "C:/path1/path1;C:/path2/path2"
>     Also in QtCreator in my particular App under Projects I see System
>     Environment variable
>     MER_SSH_SHARED_SRC = C:/path1/path1;C:/path2/path2.
>     So far so good.
>     Me thinking change settings -> all is well.
>     However the following changes did not change anything.
>     1) in the MerSDK VM under Shared Folders changed:
>     src1 to C:/path1/path1 or
>     tried with src, src2 etc.
>     2) in
>     C:\PATH_TO\SailfishOS\share\qtcreator\SailfishAlpha3\qtcreator\mersdk.xml
>     changed SharedSrc to C:/path1/path1 or C:\path1\path1
>     3) tried to override MER_SSH_SHARED_SRC in the particular project
>     with only
>     C:/path1/path1 or C:\path1\path1
>     Nothing helps :( Every time i remove Mer SDK under Options and add
>     it, first QtCreator sees only the one correct folder
>     C:\path1\path1 , but after Apply and invoking Options again it
>     shows me
>     C:/path1/path1;C:/path2/path2.
>     I also searched in the filesystem C:\ for all files containing string:
>     C:/path1/path1;C:/path2/path2
>     or only
>     C:/path2/path2
>     there is nothing left in any .ini, .txt, .vbox etc. files.
>     Any hints? What am I possibly doing wrong. I am not able to
>     compile any project, as it gets me the error: Project is outside
>     of mer shared src "C:/path1/path1;C:/path2/path2"
>     The only way I see, how to work around this, is to delete and
>     install sailfishos again :(
>     br
>     simon:-)
> _______________________________________________
> SailfishOS.org Devel mailing list

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.sailfishos.org/pipermail/devel/attachments/20140115/667387d2/attachment.html>

More information about the Devel mailing list