[SailfishDevel] MerSDK VM - "src" folder change (under Windows) not possible

Simon Bolek simon.bolek at googlemail.com
Tue Jan 14 15:14:21 UTC 2014

I have a difficulty in changing src shared folder for VM MerSDK in
QtCreator. It seems impossible right now.
Working on windows 7 with the latest SailfishOS installed.

While installing I set, stupid me, Project Folder to:
thinking QtCreator would understand both. After that started a project and
noticed that QtCreator  does not accept that.

Tools->Options->Mer: MerSDK-"Shared Folders"-"src"
I see
Also in QtCreator in my particular App under Projects I see System
Environment variable
MER_SSH_SHARED_SRC = C:/path1/path1;C:/path2/path2.

So far so good.
Me thinking change settings -> all is well.
However the following changes did not change anything.

1) in the MerSDK VM under Shared Folders changed:
src1 to C:/path1/path1 or
tried with src, src2 etc.

2) in
changed SharedSrc to C:/path1/path1 or C:\path1\path1

3) tried to override MER_SSH_SHARED_SRC in the particular project with only
C:/path1/path1 or C:\path1\path1

Nothing helps :( Every time i remove Mer SDK under Options and add it,
first QtCreator sees only the one correct folder C:\path1\path1 , but after
Apply and invoking Options again it shows me

I also searched in the filesystem C:\ for all files containing string:
or only
there is nothing left in any .ini, .txt, .vbox etc. files.

Any hints? What am I possibly doing wrong. I am not able to compile any
project, as it gets me the error: Project is outside of mer shared src

The only way I see, how to work around this, is to delete and install
sailfishos again :(

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.sailfishos.org/pipermail/devel/attachments/20140114/ab05ead9/attachment.html>

More information about the Devel mailing list