[SailfishDevel] No inbox?

Norbert Wenzel norbert.wenzel.lists at gmail.com
Fri Jan 10 08:53:38 UTC 2014


On 01/09/2014 06:16 PM, Reto Zingg wrote:
> On 09.01.2014 19:03, Markus Svensson wrote:
>> Does the mail app log errors somewhere on the device?
>
> If you have developer mode enabled, set in
> /home/nemo/.config/QtProject/Messageserver.conf:
>
> [StdStreamLog]
> Enabled=1
>
> Then run message server in foreground
> pkill messageserver5; /usr/bin/messageserver5
> and reproduce, any errors?

Reto, thanks for that. This was the only way to debug my mail settings. 
This is now the first time I'm running two of my mail accounts (Gmail 
and GMX (a german provider)) and they both are able to receive and send 
mails at the same time.

What was strange was that Gmail actually worked before until I ran out 
of power. It seems my google credentials had been lost and I had to 
login using the account manager again. But though the account manager 
told everythin was ok and I could use Google Talk and mail the mail app 
could not connect. Restarting the mailapp did not work and I had to 
restart the whole phone.

I've seen similar problems with the mail-only GMX account, but there I 
only had to retype my password (though the account manager showed the 
correct number of dots, so it looked as if a valid password has been 
entered before) after the low-power shutdown and only start the mailapp 
again.

Is it possible that some credentials are lost sometimes and credential 
updates are not always signalled to the mailapp? I think might have been 
the source for my problems with setting up mail. I entered the correct 
details and actually connected successfully (when reading the logs) but 
the mailapp still showed connection errors. So without the log I changed 
the account settings again instead of just restarting the mailapp/phone.

Norbert


More information about the Devel mailing list