[SailfishDevel] mersdk: Problem: nothing provides mesa-llvmpipe-libGL

Juha Kallioinen juha.kallioinen at jolla.com
Tue Aug 19 05:56:02 UTC 2014


On 18.08.2014 22:19, bsq at xyz.de wrote:
> Hi,
>
> in mersdk trying to install development-package for GL:
>
> [sdk] $ sb2 -t SailfishOS-armv7hl -m sdk-install -R
> [sdk] # zypper in mesa-llvmpipe-libGL-devel
>
> Problem: nothing provides mesa-llvmpipe-libGL = 9.2.5+git1-1.2.7 needed by mesa-llvmpipe-libGL-devel-9.2.5+git1-1.2.7.armv7hl
>   Solution 1: do not install mesa-llvmpipe-libGL-devel-9.2.5+git1-1.2.7.armv7hl
>   Solution 2: break mesa-llvmpipe-libGL-devel-9.2.5+git1-1.2.7.armv7hl by ignoring some of its dependencies
> Choose from above solutions by number or cancel [1/2/c] (c):
>
> Solution 2 obviously does not solve the problem: cannot find -lGL
>

Hello,

you've found a bug in the mesa packaging. The mesa-llvmpipe-libGL-devel 
package should not be available since we don't provide the corresponding 
library package.

Instead of libGL you should probably use mesa-llvmpipe-libEGL-devel or 
mesa-llvmpipe-libGLESv2-devel.

Best regards,
  Juha



More information about the Devel mailing list