[SailfishDevel] rpm repositories in emulator are not refreshed in latest SDK

christopher.lamb at thurweb.ch christopher.lamb at thurweb.ch
Sat Oct 26 16:11:45 UTC 2013


Hi Jarko

I don't know if this is related (but it sounds like it ...)

On first using zypper after the update, it only showed installed  
packages (as opposed to all those available). zypper refresh cured it

Chris

Zitat von "Jarko Vihriala" <jarko.vihriala at jolla.com>:

> Hello all,
>
> We discovered that PackageKit that is used in our emulator does not  
> automatically refresh repositories so if your rpmbuild requires  
> additional stuff to be pulled to emulator - it will eventually fail.
> <https://connect.emailsrvr.com/owa/?ae=Item&a=New&t=IPM.Note&cc=MTQuMy4xNTguMSxlbi1VUyw0Mjk0OTY3Mjk1LEhUTUwsMCww&pspid=_1382779855830_872310806#>
>
> Good news is that quickfix is in the works and should be out next  
> week. But before that is applicable this workaround needs to be done:
> 1. login to emulator (best is to press ctrl-<f-keys> on emulator's  
> window to get login prompt) as root. On my ubuntu f2 seems to cut it.
> 2. refresh repos with 'pkcon refresh'
> optionally then:
> 3. test that repos got refreshed (do f.ex 'pkcon search  
> sensorfw-qt5-devel') if you see stuff like 'Available..' then your  
> emulator has updated lists and you're good to go. If not - run 2)  
> again.
>
> Sorry for the extra trouble, we'll publish new emulator soon and it  
> is delivered via SDK update (you'll get notice in Qt Creator's UI on  
> that).
>
> thanks, Jarko
>
>





More information about the Devel mailing list