[SailfishDevel] Deployment error in new Alpha SDK

Michael Faro-Tusino mfaro-tusino at live.com
Fri Aug 2 06:14:25 UTC 2013

Hi Chris,

Sorry, forgot about that. I am running on 32-bit Ubuntu.

I successfully could SSH into the Mer VM (haven't tried to go into the emulator yet though - currently away from my machine).


Sent from my Windows Phone
From: christopher.lamb at thurweb.ch<mailto:christopher.lamb at thurweb.ch>
Sent: ‎2/‎08/‎2013 4:08 PM
To: Michael Faro-Tusino<mailto:mfaro-tusino at live.com>
Cc: devel at lists.sailfishos.org<mailto:devel at lists.sailfishos.org>
Subject: Re: [SailfishDevel] Deployment error in new Alpha SDK


You don't say what your host platform is.

Running on OSX I don't have this problem - I can start up the default
"Hello Sailors" project on the Emulator.

The error sounds like an SSH problem. Have you tried SSHing to the SDK
and Emulator from a terminal / cmd / console?.


Zitat von "Michael Faro-Tusino" <mfaro-tusino at live.com>:

> Hi guys,
> First up, congrats to the guys on releasing the new SDK.
> I thought the first thing I would do after updating would be to see
> how my existing project works with the new SDK (namely just making
> sure it would run, deploy etc).
> I ran into a build error though, so I decided to try deployment
> using the project template (to make sure it was in fact my project
> and not to do with the SDK). However, I got a deployment error
> (copied below).
> ssh: connect to host port 22: No route to host
> rsync: connection unexpectedly closed (0 bytes received so far) [sender]
> rsync error: error in rsync protocol data stream (code 12) at
> io.c(605) [sender=3.0.9]
> 14:45:08: The process
> "/home/michael/.config/SailfishAlpha/mer-sdk-tools/MerSDK/SailfishOS-i486-x86/deploy" exited with code
> 12.
> Error while building/deploying project testDeploy (kit:
> MerSDK-SailfishOS-i486-x86)
> When executing step 'Rsync'
> Any ideas on how to fix it? (Or even if anyone else has the same issue).
> Thanks,
> Michael
> -------------------------Michael Faro-TusinoSenior EditorMy Nokia Blog
> Twitter: @MFaroTusino
> Website: My Nokia BlogEmail:  mike.mnb at outlook.com

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.sailfishos.org/pipermail/devel/attachments/20130802/0473f9c3/attachment.html>

More information about the Devel mailing list